popolon has quit [Quit: Quitte]
n01 has quit [Ping timeout: 240 seconds]
deasy has quit [Quit: Nom d'un quark, c'est Edmonton !]
UnaClocker has quit [Quit: I'll be back another time]
Vanfanel has joined #cubieboard
<Vanfanel> Hi there
<Vanfanel> are there instructions to flash new Android img files to NAND from withing the Cubieboard running Debian Linux itself?
<Vanfanel> It's VERY difficult for me to enter FEL mode because I have to remove the board from it's case, and that's not easy
wolfy has quit [Ping timeout: 252 seconds]
numbie has quit [Quit: Leaving]
uizex1 has quit [Quit: If your not living on the edge, you're taking up too much space]
cjoe has joined #cubieboard
kivutar has quit [Quit: Ex-Chat]
Vanfanel has quit [Quit: Lost terminal]
stefanro1 has joined #cubieboard
stefanro has quit [Ping timeout: 245 seconds]
Mr_Electronico has joined #cubieboard
<Mr_Electronico> Is possible install any Linux system in Cubieboard ?
<ttmrichter> Mr_Electronico: Well, you can't install a Linux system compiled for x86 obviously.
<Mr_Electronico> Ok..then how I can install ?
<Mr_Electronico> How I can translate any Linux system to Cubieboard
Mr_Electronico has quit [Quit: Leaving]
<ttmrichter> You get a Linux system compiled for the A10/20 (as appropriate) or you build one yourself.
<ttmrichter> You're kind of asking here "how can I make a chocolate chip cookie out of broccoli".
<ttmrichter> It's ... just not a sensible question.
numbie has joined #cubieboard
numbie has joined #cubieboard
numbie has quit [Changing host]
FourthDr has joined #cubieboard
anas_xrt has joined #cubieboard
anas_xrt has quit [Client Quit]
madmaxx has quit [Remote host closed the connection]
madmaxx has joined #cubieboard
madmaxx has quit [Changing host]
madmaxx has joined #cubieboard
numbie has quit [Quit: Leaving]
nils_2_ has joined #cubieboard
nils_2 has quit [Ping timeout: 248 seconds]
nils_2_ is now known as nils_2
hipboi_ has quit [Ping timeout: 272 seconds]
penghb has quit [Ping timeout: 250 seconds]
hipboi_ has joined #cubieboard
hramrach has joined #cubieboard
backb0ne_ has quit [Remote host closed the connection]
ganbold__ has quit [Remote host closed the connection]
UnaClocker has joined #cubieboard
TheSeven has quit [Disconnected by services]
[7] has joined #cubieboard
datagutt has quit [Ping timeout: 252 seconds]
ganbold__ has joined #cubieboard
backb0ne has joined #cubieboard
caveat- has quit [Ping timeout: 264 seconds]
caveat- has joined #cubieboard
<Gumboot_> ttmrichter: I think he meant any Linux distribution.
Gumboot_ is now known as Gumboot
bizarro_1 has quit [Quit: Leaving]
<Gumboot> And since so many of them support ARMv7 (distinct from the pi situation) the answer's near enough to yes.
t3st3r has quit [Remote host closed the connection]
t3st3r has joined #cubieboard
Fangorn has quit [Ping timeout: 240 seconds]
penghb has joined #cubieboard
tomboy65 has joined #cubieboard
tomboy64 has quit [Ping timeout: 272 seconds]
deasy has joined #cubieboard
n01 has joined #cubieboard
pacopad has joined #cubieboard
rellla has joined #cubieboard
tomboy64 has joined #cubieboard
tomboy65 has quit [Ping timeout: 250 seconds]
kivutar has joined #cubieboard
qermit has quit [Remote host closed the connection]
backb0ne has quit [Remote host closed the connection]
Baronawesome has quit [Ping timeout: 240 seconds]
Krispis has joined #cubieboard
Baronawesome has joined #cubieboard
emx has joined #cubieboard
<emx> i can't compile firefox or opera for gentoo on cb2. i guess some code has to be arm-specific. which browser can i use with cb2 that can cope with today's technology?
<Wizzup> what is the error?
<Wizzup> I have fireox working fine
<Wizzup> gentoo on cb2
n01 has quit [Ping timeout: 240 seconds]
<Wizzup> emx: perhaps neon related?
<Wizzup> also, do you have enough ram?
<emx> Wizzup, just a sek. i try to emerge to tell you the exact error message.
<emx> *sec
<Wizzup> You'll have the error that fast?
<emx> Wizzup, which resolution do you use in X?
<Wizzup> I am not actively using my cb2 atm
<Wizzup> Why do you ask
<Wizzup> Typically 1080p
<emx> Wizzup, yes. it is the binary btw.
<Wizzup> Oh..
<Wizzup> emx: That will not work
<emx> Wizzup, i use fbturbo as gfx driver at it only goes up to 720p
<Wizzup> Do you have pulseaudio enabled?
<Wizzup> emx: I doubt that somehow @ gbturbo :)
<emx> Wizzup, when i try to emerge firefox (not -bin) i get another error message in libvpx.
<Wizzup> which error
<Wizzup> I can help with that
<emx> Wizzup, i think no. why?
<Wizzup> probably just need libvpx stable
<Wizzup> emx: I may have a binary build somewhere
<Wizzup> no guarantees
<emx> Wizzup, let's try the hard way first :)
<Wizzup> emx: I recall you need newer - unstable - libvps
<Wizzup> vps
<Wizzup> has something to do with new glibc and upstream advice is to get new version
<Wizzup> vpx
<Wizzup> so 1.2.0-pre
<emx> ok. stable is 1.1.0. is there an ebuild?
<Wizzup> You can try one of these, but yeah, no clue if it'll actually work
<Wizzup> I don't recommend my binpkg for anything atm, as I am switching to hardened, but firefox is still without hardening
<Wizzup> emx: in portage there is also a 1.2.0-pre
<Wizzup> media-libs/libvpx
<Wizzup> Available versions: 1.1.0 ~1.2.0_pre20130625 **9999
<emx> i'll try it soon.
<emx> Wizzup, which tutorial did you use for the X11 driver?
Vanfanel has joined #cubieboard
initbrain has quit [Ping timeout: 246 seconds]
<emx> Wizzup, "collect2: error: ld returned 1 exit status"
<Wizzup> emx: need more info than that
initbrain has joined #cubieboard
Fangorn has joined #cubieboard
<Vanfanel> ssvb: AreaScout and I have two different MALI(GLES/EGL) and LIMA backends for RetroArch, but we're having problems with vsync. The ioctl I'm using, FBIO_WAITFORVSYNC, is causing the emulation of all systems to be very slow. Isn't there a way to simply activate EGL vsync so there's no need for this ioctl before calling eglSwapBuffers() ???
<Fangorn> Hello
<emx> Wizzup, X11 is a dead link, right?
<Fangorn> Any try connect dac over spi or i2s?
<Wizzup> emx: it appears so, ask swabbles
<Wizzup> swabbles: PING
<ssvb> Vanfanel: FBIO_WAITFORVSYNC naturally limits the framerate to 60 frames per second, and it needs to be called after (not before) eglSwapBuffers to avoid tearing
<Fangorn> Nobody?
* Wizzup has not yet
<Wizzup> swabbles: Have you considered making a cubieboard overlay?
<Vanfanel> ssvb: thanks for the clearing!! I run to test it NOW!! :D
<Wizzup> swabbles: Maybe we should
<Fangorn> I see alsa for soc don't support allwinner
<Fangorn> But i found ready for use dac extension for cubie, but for 300-400$
<Fangorn> Anyone has it?
<emx> Wizzup, did you crosscompile your gentoo?
<Wizzup> No
<Wizzup> I did use binpkg for it, because my ODROID has a binpkg
* Fangorn also have question... how you use your cubie?
<Wizzup> Fangorn: cubieboard audio should just work
<Wizzup> afaik
<emx> Wizzup, k. which one do you like better for playing fullHD movies?
<Wizzup> emx: Cannot comment. I have seen swabbles playing fullhd movies on his cubie.
Krispis has quit [Ping timeout: 246 seconds]
<Wizzup> Odroid, I mostly use it as build server and desktop
<Wizzup> never got hw decoding ti work
<emx> where is that swabbles guy?
<Wizzup> in here.
<Wizzup> Never put a lot of effort in trying to get odroid hw decoding to work though
<Wizzup> He sleeps at the weirdest times though
<Wizzup> ;-)
<emx> hehe
<Fangorn> Wizzup: I intresting to use more quallity dac
<emx> i started the emerge with the unstable libvpx. unfortunately python has to be recomplied so it will take some time.
<Wizzup> Fangorn: maybe a usb audio card?
<Wizzup> emx: heh, firefox will take hours
<Wizzup> make sure you have some swap on a HDD (not microsd)
<Wizzup> and please dont compile on microsd. they break
<Wizzup> :)
tomboy64 has quit [Ping timeout: 240 seconds]
<emx> Wizzup, good point. seems like i need to reswap to my ssd.
<Fangorn> Yep. But more intresting use own diy extension )
<Wizzup> yes, probably
<Wizzup> emx: or just mount /var/tmp/portage on it
<Wizzup> Fangorn: okay,then I do not know
<Fangorn> Gentoo at cubie work? How many time spend compiling all at cubie?
<Wizzup> gentoo works on _ALL_ the things
<Fangorn> Or all use crosscompilling?
<Wizzup> And darn well, too :)
<Wizzup> Fangorn: As stated, I compiled a lot on my quad core arm, but compiling on cubie works fine too
<Fangorn> I like gentoo )
<Wizzup> Just don't use microsd :))
<Fangorn> Why not at big x86 pc?
<emx> Fangorn, to loud, heat generation, wasting of current because not used...
<emx> s/to/too
<Fangorn> Hum...
EdBr has joined #cubieboard
<EdBr> hello, I good Morning
<EdBr> I have a problem with my internet on CB2
Cpt-Oblivious has joined #cubieboard
<emx> Fangorn, currently i'm sitting at an octacore laptop and all i do is chatting in irc and browsing.
<EdBr> I use wifi but it doesn't work
<emx> EdBr, hi. thanks for telling :o)
<Wizzup> Fangorn: cross compiling is not always easy
<Wizzup> typically you end up with qemu-user and stuff
<Wizzup> A bit of a pain
<Wizzup> Some packages do not like being cross compiled
<Wizzup> I found either using a different ARM machine (same arch) or just on the device itself is easier
<EdBr> Hi emx thank
<EdBr> I install here
<Fangorn> I don't try crosscompilling. But will try, think
<EdBr> emx: I have configure my internet?
<EdBr> sorry my bad english. I'm from Brazil
<Fangorn> EdBr - it's question?
<Fangorn> I'm from Russia )
<EdBr> Fangorn: how can I make my wifi work? I have already connected to my network but not enter into any site.
<Fangorn> Bear, vodka, matreshka )
<Fangorn> Try ifconfig command
<Fangorn> How you see what you connected?
<Vanfanel> ssvb: calling ioctl(fb, FBIO_WAITFORVSYNC, 0) after eglSwapBuffers() doesn't work: refresh isn't synced at all.
<Vanfanel> ssvb: But if called before, vsync seems to work, but since that ioctl is blocking, it prevents CPU from working on new frames.
<emx> EdBr, did you check if your wlan device is recognised by linux?
tomboy64 has joined #cubieboard
<emx> (lsusb)
<emx> Wizzup, do you mind pasting your make.conf (and maybe package.*) and your xorg.conf?
<EdBr> Fangorn: I conected my wifi,when I enter in browser i have a "server not found"
<Fangorn> Use ifconfig command in terminal and post it
<EdBr> I don't know with configure my device
<Fangorn> Here
<emx> EdBr, which distribution do you use (debian, cubian, ubuntu, gentoo, arch linux?)
<ssvb> Vanfanel: to get CPU working on new frames you can do this in a separate thread
<Wizzup> emx: from cubie? dont have that here.
<Wizzup> Sorry, cannot help atm with that
<EdBr> emx: I use cubie
<EdBr> cubian
<ssvb> Vanfanel: as for vsync, this does not make much sense
<EdBr> U use this image
<Wizzup> emx: I am actually using gentoo on cubie2 for work, so I'll definitely get back to you
<Wizzup> probaby with guides, later
<emx> Wizzup, k. i just realised that the last commit to "gentoo-on-arm" removed X11.md.
<Fangorn> EdBr - you see my messages?... )
<EdBr> emx: I use Nand Image
<Wizzup> emx: heh
<emx> Wizzup, did you use the overlay, btw?
<Vanfanel> ssvb: thanks
<EdBr> Fangorn: when I conected I see "server not found"
<emx> EdBr, then tell us what lsusb lists.
<ssvb> Vanfanel: FBIO_WAITFORVSYNC waits until the previously scheduled FBIOPAN (called from eglSwapBuffers) takes effect
uizex1 has joined #cubieboard
<emx> EdBr, you can use pastebin.com or pastie.org to post your output.
<Fangorn> emx - they say that already connected to wifi. Think all right with hardware
<Vanfanel> ssvb: the problem here is that, sadly, I'm getting a way slower gles performance from the Cubieboard2 than I get from the Raspberry Pi for RetroArch using GLES, IF I use that ioctl to wait for vsync. So, isn't there another way around this?
<emx> then the question is if there is a networkmanager installed.
<EdBr> emx: Bus 002 Device 002: ID Obda: 8179 Realtek Semiconductor Corp.
<Vanfanel> ssvb: The Cubie2 is supposed to be 3 times as powerfull in bot CPU and GPU than the Pi, so RetroArch, using GLES in both cases, should perform accordingly
<emx> EdBr, k, so your device is running. what does ifconfig output?
<ssvb> Vanfanel: 3 times more powerful for GPU? why would you think so?
<EdBr> emx: yes it work, but not conect.
<Vanfanel> ssvb: doesn't the Cubie2 have twin MALI400 GPUs? Maybe I'm mistaken...
<EdBr> emx: when I enter in webpage I see "server not found"
<Fangorn> Emx - i think they use network manager to connect
<emx> EdBr, please post output of ifconfig
<emx> Fangorn, i guess so.
* Fangorn write to EdBr pm
<emx> k
<Fangorn> EdBr - you really can't open terminal?
<ssvb> Vanfanel: doesn't Rpi have four (or sixteen?) GPU cores?
<Vanfanel> ssvb: Yes, but all the GPU does here is to render a texture.
<EdBr> emx: one minute because I have write in my notebook
<EdBr> hehe
<Fangorn> ...hehe...
<Fangorn> Who use spi or i2s at cubie?
<ssvb> Vanfanel: hmm, this infor about the rpi gpu is a bit confusing - https://github.com/hermanhermitage/videocoreiv-qpu
<ssvb> Vanfanel: on one hand it says "Videocoreiv Quad Processor Units", but on another hand it also says "Dualcore Videocore IV CPU @250MHz with SIMD Parallel Pixel Units (PPU)"
<emx> EdBr, and output of ifconfig?
<Fangorn> Hum...
<ssvb> Vanfanel: what you need to do is to clearly identify what is the source of the performance bottleneck
<Vanfanel> ssvb: it's clear: the ioctl call to wait for vsync
<ssvb> Vanfanel: profiling with perf or oprofile can help to see if anything is hogging the cpu
<ssvb> Vanfanel: sorry, but "it works for me" (tm) :)
<Vanfanel> ssvb: do you mean you've tested RetroArch + GLES on your Cubie2 and it works well for you??
<ssvb> Vanfanel: I have no idea what RetroArch is
<ssvb> Vanfanel: what I say is that tear-free OpenGL ES works fine without extra overhead
wolfy has joined #cubieboard
<Vanfanel> ssvb: it's an API for lagless emulation: https://github.com/libretro
<Vanfanel> ssvb: would you please give RetroArch a go on the Cubie2?
<EdBr> emx: now my device reboot when i conected internet
<Vanfanel> ssvb: out repo with fb/EGL/GLES support is here: https://github.com/AreaScout/RetroArch
<EdBr> : (
<Vanfanel> ssvb: you simply have to build with GLES support and try an SNES game with the SNES9x-next core
gregor3005 has joined #cubieboard
pacopad has quit [Quit: pacopad]
<gregor3005> hi, today i tested a hd video on my cb3 with lubuntu and mplayer. it stucks very but. i run lubuntu from an 2.5" sata hdd (40mb/s with dd)
<gregor3005> the sound is great, its an mkv file. avi files with lower resolutions run perfect
<EdBr> emx:
<EdBr> sorry
<emx> EdBr, do you connect both cable and wifi? maybe you should /etc/init.d/net.eth0 stop (don't know if that works in cubian. or simply unplug cable.)
initbrain has quit [Changing host]
initbrain has joined #cubieboard
<EdBr> emx: when I connect cable in my dive it reboot
<emx> EdBr, did you configure your nic (the thing you plug the cable in)? or didn't you configure anything?
datagutt has joined #cubieboard
<EdBr> emx: I didn't configure anything
<emx> do you try to connect to the internet with the cable plugged in?
<EdBr> emx: I just intall cubian
<EdBr> emx: when I connect cable my device reboot
<emx> EdBr, that's not what i'm asking. is the cable plugged in right now?
<EdBr> yes
<EdBr> emx: I connect now my cable
<emx> don't
<EdBr> emx: I connect my cable and my internet work now
<emx> EdBr, what happens when you call "ifdown eth0"?
<emx> Wizzup, pulseaudion doesn't configure (configure: error: XML::Parser perl module is required for intltool)
<emx> any help?
<Fangorn> Disconnect cable
<EdBr> emx: ifdown eth0 RTNETLINK answers: No such process
<Wizzup> emx: did you emerge it with nodeps?
<emx> Wizzup, checking
<EdBr> emx: cable doesn't work ok?
bizarro_1 has joined #cubieboard
<emx> EdBr, i assume that cubian tries to use eth0 (cable) to connect to the internet weather it is plugged in or not.
<Fangorn> Emx - think eth0 is down then cable out
<emx> Wizzup, what do you mean by nodeps? i don't see that useflag.
<Fangorn> EdBr - unplug cable and do ifconfig
<emx> Fangorn, then why did he have an ip adress if he didn't configure eth0, i.e. when the ip is assigned dynamically to eth0?
<Fangorn> I think they do ifconfig with cable
<Fangorn> Nope?
<EdBr> emx: ifconfig with cable and adapter wifi
<Fangorn> Tada )
<emx> EdBr, then do ifconfig wihtout cable plugged in.
<emx> also pot output of route
<emx> *post
<Wizzup> emx: if you dont know it, nevermind
<Wizzup> try asking in #gentoo
<emx> Wizzup, k, thanks.
<EdBr> emx: now i disconnect wifi
<EdBr> just a minute
AndrevS has quit [Quit: Leaving]
<Fangorn> Emx eth0 is down
<EdBr> emx: without cablet plugged in
<EdBr> emx: now my divice work internet
<EdBr> emx: I reboot my device. OK?
<emx> EdBr, yes, but without cable plugged in.
<EdBr> emx: only wifi adapter
<EdBr> emx: work only wifi adapter
<Fangorn> Internet work with wifi?
<Fangorn> I see traffic
<EdBr> emx: just a minute. I reboot my divice
<EdBr> emx: not work now
<EdBr> emx: when I reebot my device only adapter wifi . it doesn't work
<EdBr> : (
<EdBr> emx: what best OS for CB2?
<Wizzup> gentoooooo
<Wizzup> If you have prior knowledge
Fangorn has quit [Ping timeout: 240 seconds]
wolfy has quit [Ping timeout: 252 seconds]
<EdBr> emx: any Idea?
old-papa has quit [Read error: Connection reset by peer]
<Vanfanel> ssvb: ok... if you look here: http://www.khronos.org/registry/egl/sdk/docs/man/xhtml/eglSwapInterval.html, it seems to me that eglSwapBuffers() SHOULD wait for vsync
<Vanfanel> ssvb: so, there should be no need for the FBIO_WAITFORVSYNC ioctl at all.
<Vanfanel> ssvb: any idea on why it doesn't work as it should??
<ssvb> Vanfanel: you are free to send a bugreport to ARM
<emx> EdBr, what happens when you boot up with cable plugged in and then remove the cable? does wifi work?
<Vanfanel> to ARM holdings??? :D
<Vanfanel> ssvb: seriously, where should I report this?
<Vanfanel> ssvb: ok, what other options, other than using /dev/fb* or X11, do we have for the EGL context?
<Vanfanel> ssvb: ok, thanks
deasy has quit [Quit: Nom d'un quark, c'est Edmonton !]
infobot has quit [Ping timeout: 260 seconds]
<EdBr> emx: I just connect the cable and the wifi works perfectly. if I disconnect the cable it still works, but if I restart the CB it does not work the wifi
<EdBr> emx: now I edit vi /etc/network/interfaces
<EdBr> auto wlan0 iface wlan0 inet dhcp
<emx> EdBr, that was my assumption but i don't know how to fix it. maybe you should ask in #debian. they should be able to help.
D0pamine has joined #cubieboard
infobot has joined #cubieboard
<EdBr> emx: what SO do you use?
rellla has quit [Quit: Nettalk6 - www.ntalk.de]
Krispis has joined #cubieboard
Juerd_ has joined #cubieboard
Juerd_ has quit [Client Quit]
Juerd_ has joined #cubieboard
Juerd has quit [Quit: leaving]
Juerd_ is now known as Juerd
zn414 has joined #cubieboard
zn414 has joined #cubieboard
zn414 has quit [Changing host]
<emx> EdBr, gentoo
<emx> but you need lots of experience with it.
<emx> best start with linux from scratch.
Krispis has quit [Ping timeout: 272 seconds]
<emx> that makes you understand linux quite well.
<EdBr> emx: well, i think try fedora
<EdBr> i have a problem now after edit /etc/network/interfaces
<EdBr> when I write my login and password my device restart
Baronawesome has quit [Ping timeout: 240 seconds]
Baronawesome has joined #cubieboard
kivutar has quit [Ping timeout: 260 seconds]
Fangorn has joined #cubieboard
wolfy has joined #cubieboard
pythonsnake has quit [Quit: WeeChat 0.4.0]
<wooy> EdBr: debian
old-papa has joined #cubieboard
qermit has joined #cubieboard
n01 has joined #cubieboard
<EdBr> wooy: thank you. I use Linux Mint in my laptop
<EdBr> I like debian but is very difficult
kivutar has joined #cubieboard
tomboy64 has quit [Ping timeout: 240 seconds]
<Fangorn> EdBr - your wifi is working?
<EdBr> Fangorn: yes. now my wifi work
<EdBr> Fangorn: I edit /etc/network/interfaces
<Fangorn> And? Delete eth0?
tomboy64 has joined #cubieboard
<EdBr> Fangorn: disabled eth0
<EdBr> #
<EdBr> Fangorn: auto wlan0
<EdBr> and I set IP, netmask, gateway
EdBr has quit [Ping timeout: 272 seconds]
EdBr has joined #cubieboard
<EdBr> Fangorn: now it OK with mi wifi. Thank you
<EdBr> Fangorn: my problem now is HDMI. display
<EdBr> hehe
<EdBr> emx: Now my wifi work very well
<EdBr> thank for your help
wolfy has quit [Ping timeout: 252 seconds]
<Fangorn> What with hdmi?
<EdBr> in my TV when I set 16:9 the image is larger than the screen of the TV, so the menu bar is missing
wolfy has joined #cubieboard
penghb has quit [Remote host closed the connection]
<swabbles> Wizzup: the only things that would end up in such an overlay would be the existing libvdpau-sunxi and x11-video-fbturbo ebuilds, though.
<Wizzup> cubie-sources?
<Wizzup> Until mainlined, of course
tomboy65 has joined #cubieboard
<swabbles> Would prefer to call that sunxi-sources, though.
<Wizzup> Sure...
<Wizzup> I'll just put it in grand tree
<swabbles> emx: I've compiled most packages on the Cubieboard 2 itself, used my Samsung ARM Chromebook for firefox.
<Wizzup> Soon I'll get some more cubie2s
tomboy64 has quit [Ping timeout: 248 seconds]
EdBr has quit [Quit: Page closed]
cjoe has quit [Read error: Connection reset by peer]
kivutar has quit [Quit: Ex-Chat]
kivutar has joined #cubieboard
n01 has quit [Ping timeout: 248 seconds]
<Vanfanel> ssvb: this is the question I made in the arm devs center: http://community.arm.com/thread/4815
<Vanfanel> ssvb: just in case you want to take a look and tell me what do you think
wolfy has quit [Ping timeout: 252 seconds]
rz2k has joined #cubieboard
wolfy has joined #cubieboard
wolfy has quit [Ping timeout: 252 seconds]
rellla has joined #cubieboard
Turl has quit [Ping timeout: 252 seconds]
Turl has joined #cubieboard
Turl has quit [Changing host]
Turl has joined #cubieboard
tomboy64 has joined #cubieboard
deasy has joined #cubieboard
tomboy65 has quit [Ping timeout: 248 seconds]
<kenny> Is there any kind of feature matrix on what is supported for which chips in which kernels?
<emx> swabbles, compiling libvpx in version 1.2.0_pre was the key. now i'm into a few hours compiling firefox. let's see how it works out.
<emx> swabbles, but what i didn't manage is setting a resolution of 1920x1080.
<emx> with fbturbo it's at 720p atm.
Tekkharibo has quit [Read error: Operation timed out]
DV_ has quit [Read error: Operation timed out]
Tekkharibo has joined #cubieboard
DV_ has joined #cubieboard
n01 has joined #cubieboard
niftylettuce has quit [Ping timeout: 246 seconds]
niftylettuce has joined #cubieboard
<ssvb> emx: the screen resolution is initially set by the kernel (taken from script.bin or from monitor EDID or from kernel cmdline)
<ssvb> emx: try to add "disp.screen0_output_mode=1920x1080p60" to the kernel cmdline
<ssvb> emx: or basically have a look at http://linux-sunxi.org/Display#Changing_resolution
<kenny> What kernel that's 3.8 or later is recommended on the CB2 for mmc, ethernet, and usb support? (mainline 3.13? sunxi-next?)
madmaxx has quit [Ping timeout: 246 seconds]
<ssvb> kenny: none
<ssvb> kenny: or the very latest if you are really adventurous
<kenny> ssvb: I'm adventurous, and it's not a critical system or anything. My latest you mean sunxi-next? or sunxi-devel? (or something else)
<kenny> I'm okay with 'should work', I'm just trying to figure out what is supported where
<kenny> (I'm looking to see if I can get docker.io running on it)
<kenny> cool, thank you. I'll give that a shot
<emx> ssvb, what exactly is EDID? i thought it reads out the capabilities of the monitor and my monitor is capable of 1080p...? but i will try your suggestion.
<emx> how stupid is it to start virtualbox with gentoo armv7a as guest and compile from there?
<ssvb> emx: if you want it to read the resolution from your monitor, then you need "disp.screen0_output_mode=EDID"
<emx> i got disconnected, so i don't know if my second message went through. here it is again: how stupid is it to start virtualbox with gentoo armv7a as guest and compile from there?
<ssvb> don't know, does virtualbox support arm emulation?
<ssvb> or what exactly do you want to achieve?
<emx> ssvb, i got the choice to compile with my cubieboard (slow) or with crosscompiling (will it do its job correctly?) and now i got this idea.
penghb has joined #cubieboard
<ssvb> emx: crosscompile what? the kernel is easy and fast
<ssvb> emx: but the packages in general are a major PITA
<emx> ssvb, yes. u-boot/kernel was easy. but firefox...?
<emx> ssvb, maybe that's the easiest way.
<emx> although they need to update chapter "boards" :P
FR^2 has joined #cubieboard
<ssvb> emx: the easiest way is just to buy some fast arm hardware and use it as a build machine :)
<ssvb> emx: you can also compile natively on the cubieboard, but setup distcc
<ssvb> emx: so that it would get a help from your desktop pc
<emx> ssvb, so there are no architecture-limits in distcc?
<emx> interesting.
<emx> does it have to be another gentoo box?
<ssvb> emx: obviously you have to setup distcc with an arm crosscompiler
<ssvb> emx: yes, preferably another gentoo box, because you want the crosscompiler to be exactly matching the compiler from your arm device
<emx> easier done than said.
<ssvb> yes, that's why a fast arm build machine is the easiest :)
<emx> ssvb, what is there on the market that is arm and fast? i only know about ondroid and wandboard.
<ssvb> odroids are probably the best in terms of price/performance
<emx> do they have a standalone nic-chip or is it a usb device?
<ssvb> unfortunately usb
<ssvb> cubox-i might be good, but it is very new and it is only 1GHz cortex-a9 quadcore
wolfy has joined #cubieboard
<ssvb> also there is radxa from hipboi_
<emx> i love the way the world is changing :>
<emx> what's all the cortex-AX stuff btw. it seems to me like it is an arbitrary enumeration such that one can't tell which one is the newer generation. or am i wrong?
Night-Shade has quit [Quit: Client exiting]
Night-Shade has joined #cubieboard
<ssvb> Vanfanel: I have checked the demo program with the mali framebuffer driver, and looks like it indeed has tearing problem now
<ssvb> Vanfanel: but I'm pretty sure it worked before, so some bisecting might be needed
<ssvb> Vanfanel: for another framebuffer vsync test, you can try https://github.com/ssvb/xf86-video-fbturbo/blob/master/test/sunxi_disp_vsync_demo.c (but it does not use mali)
<ssvb> Vanfanel: you can also try libhybris with android mali blobs, it handles vsync correctly, but has high cpu usage
<ssvb> Vanfanel: anyway, the ball is on your side now :)
<Vanfanel> ssvb: did you see my post here?-> http://community.arm.com/thread/4815
<ssvb> Vanfanel: yes
<Vanfanel> ssvb: if you look at my post, my code and the docs I link, it's obvious that there's a problem with swap interval
<Vanfanel> eglSwapInterval (display,1) is simply ignored
tomboy65 has joined #cubieboard
<Vanfanel> always returns true
<Vanfanel> it's broken
<ssvb> Vanfanel: well, the mali driver has some glitches here and there
akaber has joined #cubieboard
tomboy64 has quit [Ping timeout: 264 seconds]
<akaber> hello , any one have gpio diagram for cubietruck ?
<ssvb> Vanfanel: but I'm more worried that FBIOPAN_DISPLAY does not seem to work nicely with FBIO_WAITFORVSYNC and this likely points to a problem in the framebuffer driver
<ssvb> Vanfanel: if you run the framebuffer gles program as 'strace -f <program-name>', you can see that the mali blob is doing FBIOPAN_DISPLAY as part of eglSwapBuffers
<ssvb> Vanfanel: it is just missing FBIO_WAITFORVSYNC there, but even if it had these ioctl calls, they would not help much
popolon has joined #cubieboard
tomboy64 has joined #cubieboard
tomboy65 has quit [Ping timeout: 252 seconds]
penghb has quit [Ping timeout: 252 seconds]
mifritscher has joined #cubieboard
<mifritscher> hi
<mifritscher> I'm interested into the cubietruck because of its all-in own approach (cpu, flash, bt, wlan etc.)
<ssvb> Vanfanel: hmm, nice, vsync seems to be also broken in libhybris now :)
<mifritscher> how crucial is a stable 5V power? Or: what is driven directly by 5V despite usb and the SATA-device? And: are the voltage regulators linar ones or switching ones?
<mifritscher> I'm asking because I'm wondering whether I can use the board on my little roboter which get its power from a USB accu
<Night-Shade> mifritscher: I have mine running off a normal usb port with a SATA SSD
<Night-Shade> I'm working it fairly hard building kernels etc
penghb has joined #cubieboard
<Vanfanel> ssvb: maybe the drivers are getting an overhaul and that's why some important features are broken?
<mifritscher> do you know how much power does it draw? I read that 500mA are enough for the board (without hdd) - if it's using lets say 300mA with enabled WLAN and sending a low res video stream from a USB-camera it would be great
<mifritscher> I hat some problems with it on the carambola, that's why I'm asking
<Night-Shade> if you are just wanting to send video there are better options
<mifritscher> I'm planing to put ros on it ;)
<mifritscher> but I don't think that ros needs much power
<Vanfanel> ssvb: maybe I should stay away from the cubie2 (for GLES on fb stuff) until the mainlined is completed?
<Vanfanel> *mainlining
<mifritscher> perhaps I'l play with olrsd as well
<ssvb> Vanfanel: if you have better options, than this would be reasonable
<Vanfanel> ssvb: yeah, I have an IFC6410 (freedreno reference board, yay!) sitting on my desk :D
<Vanfanel> ssvb: what does this sunxi_wait_for_vsync(disp) fn do under the hood? Does it also use the FBIO_WAITFORVSYNC ioctl then??
<ssvb> Vanfanel: yes
<Vanfanel> ssvb: thanks for the new example, really, but it's not the fix I need if it uses the same ioctl call that's causing me so much troube :P
wolfy has quit [Ping timeout: 252 seconds]
<ssvb> Vanfanel: that's just an example of using disp layers via some thin wrapper functions (these functions are also used for implementing scaled tear-free video overlay for xf86-video-fbturbo)
<Vanfanel> ssvb: I see :)
<ssvb> Vanfanel: the only difference is that it is not using FBIOPAN_DISPLAY
<ssvb> Vanfanel: and the sunxi disp layers seem to be working correctly with FBIO_WAITFORVSYNC
<ssvb> btw, libhybris still also works correctly after all (I just forgot that I had vsync artifically disabled for gralloc to test the performance)
mifritscher has quit [Ping timeout: 252 seconds]
<gregor3005> hi, does anybody played supertux on an cb3 with lubuntu? its is so slow. also hd movies don't work well
gregor3005 has quit [Read error: Connection reset by peer]
rz2k has quit []
gregor3005 has joined #cubieboard
<ssvb> Vanfanel: actually you can try the following simple kernel patch - https://gist.github.com/ssvb/8088519 :)
<gregor3005> a friend created a clean cubian for cb3 which support all drivers. should he publish it anywhere?
<ssvb> Vanfanel: it just forces FBIOPAN_DISPLAY to also block until next vsync
rellla has quit [Remote host closed the connection]
<ssvb> Vanfanel: seems to work here
zn414 has quit [Quit: Leaving]
<Vanfanel> ssvb: that patch has no sense: it deletes a line and adds the same line
<ssvb> Vanfanel: it uncomments this line
<Vanfanel> and it does make eglSwapInterval(display, 1) work???
lunra has quit [Remote host closed the connection]
<gregor3005> is it normal that the nand store is slower than a sd card?
deasy has quit [Quit: Nom d'un quark, c'est Edmonton !]
<ssvb> Vanfanel: I guess it forces the eglSwapInterval to 1 unconditionally, pick your poison
<Vanfanel> that's good enough for me! I will test it tomorrow.. gf is here :)
<Vanfanel> thanks!!
Vanfanel has quit [Quit: Lost terminal]
anunnaki has joined #cubieboard
uizex1 has quit [Quit: IceChat - Its what Cool People use]
n01 has quit [Ping timeout: 264 seconds]
tomboy65 has joined #cubieboard
tomboy64 has quit [Ping timeout: 248 seconds]
SirHaXalot has joined #cubieboard
<SirHaXalot> hello world :)
akaber has quit [Ping timeout: 272 seconds]
<SirHaXalot> datagutt, you here?
<SirHaXalot> any other android dev?
<SirHaXalot> ok, anyways, happy xmax and a happy new year, i hope to see some development next year for the cubietruck :)
SirHaXalot has quit [Quit: Page closed]
n01 has joined #cubieboard
popolon has quit [Quit: Quitte]
tomboy64 has joined #cubieboard
tomboy65 has quit [Ping timeout: 264 seconds]
ganbold__ has quit [Remote host closed the connection]
kivutar has quit [Ping timeout: 252 seconds]
n01 has quit [Ping timeout: 272 seconds]
kivutar has joined #cubieboard
emx has quit [Ping timeout: 250 seconds]